
RFC 10051: Task Extensions to iCalendar. The "VTODO" calendar component in the Internet Calendaring and Scheduling Core Object Specification (iCalendar; RFC 5545) has seen limited adoption and use, mainly for personal reminders and to-do lists.
This document updates RFC 5545 and defines extensions to "VTODO" to provide improved status tracking, scheduling, and specification of tasks to allow its use in other contexts, such as process control and project management.
It also defines how Calendaring Extensions to WebDAV (CalDAV) (RFC 4791) servers can be extended to support certain automated task management behaviors..
RFC EditorRFC Editor
مكون "VTODO" في مواصفات "iCalendar" الأساسية للتقويم والجدولة على الإنترنت (RFC 5545) شهد تبنيًا واستخدامًا محدودين، بشكل أساسي للتذكيرات الشخصية وقوائم المهام.
توثق هذه الوثيقة RFC 5545 وتحدد تمديدات لـ "VTODO" لتوفير تتبع وتحديد أفضل للحالة، والجدولة، والمهام لتمكين استخدامها في سياقات أخرى، مثل مراقبة العمليات وإدارة المشاريع.
كما تحدد كيفية تمديد تمديدات التقويم لـ WebDAV (CalDAV) (RFC 4791) للخوادم لدعم بعض سلوكيات إدارة المهام الآلية.